IMEIの値について

お世話になります。

Armadillo-IoT G3LのLTEモジュールを使用して通信を行っています。
下記のコマンドでLTEモジュールのIMEIを表示しようとすると、3種類のデータのどれかが表示されます。

> mmcli -m 0 | grep imei
  3GPP     |           imei: 'XXXXXXXXXXXXXXX' (15桁の数字)
  3GPP     |           imei: '000000000000000' (15桁のゼロ)
  3GPP     |           imei: 'unknown'

一番上の15桁の数値は正しい値だと思いますが、それ以外の15桁のゼロとunknownについてはどういう意味なのでしょうか。
ちなみにどの機器もLTE通信はできていますが、そういうもの(IMEIの値は無関係)なのでしょうか。
(通信できない機器は調査できないので不明)

お分かりになる方、お教えいただけると幸いです。
よろしくお願いいたします。

製品: 
Armadillo-IoT G3L

大塩です。

ご質問いただいた内容について調査しております。
お手数ですが、以下の内容についてどちらの認識が正しいかご回答いただけますでしょうか。
1. 1台の個体でコマンドを実行するたびに3GPP imeiデータが変化する。
2. 複数の個体でそれぞれ3種類のデータのどれかが表示される。それぞれの個体に表示された3GPP imeiデータが変わることはない。

よろしくお願いします。

お世話になります。

返信ありがとうございます。

> 2. 複数の個体でそれぞれ3種類のデータのどれかが表示される。それぞれの個体に表示された3GPP imeiデータが変わることはない。

基本的に上記2.の方の動作です。1台の個体では3GPP IMEIは同じです。
ただし日を変えてコマンドを入力すると、少数ですが何台かはunknownと表示されたり(正しいと思われる)IMEIが表示されたりすることはありました。
繰り返しですが、1台の個体で異なるIMEI値が表示されることはないようです。

よろしくお願いします。

大塩です。
 
> > 2. 複数の個体でそれぞれ3種類のデータのどれかが表示される。それぞれの個体に表示された3GPP imeiデータが変わることはない。
>
> 基本的に上記2.の方の動作です。1台の個体では3GPP IMEIは同じです。
> ただし日を変えてコマンドを入力すると、少数ですが何台かはunknownと表示されたり(正しいと思われる)IMEIが表示されたりすることはありました。
> 繰り返しですが、1台の個体で異なるIMEI値が表示されることはないようです。

回答ありがとうございます。

問題改善のため、以下の内容をそれぞれ3種のデータ個体に対して実施いただけますでしょうか。

・以下のブログを参考にModemManagerのデバッグログを有効にしてください。
 ■参考
 G3/G3L: ModemManagerのデバッグログを有効にする方法
 https://users.atmark-techno.com/blog/750/2508

・再起動し、起動時からの/var/log/syslogを送付していただけますでしょうか。

よろしくお願いします。

大塩様

回答ありがとうございます。

実際に稼働しているシステムなので設定を変更する場合、手続きを踏む必要がありちょっと時間がかかるかもしれません。
もし設定変更が必要ない次善の策があればありがたいのですが。

よろしくお願いします。

大塩です。

> 3GPP | imei: '000000000000000' (15桁のゼロ)
上記について、以下の文書に記載されている問題が発生している可能性があります。
以下文書を参考に、LTEモジュールのファームウェアバージョンを確認してください。
https://users.atmark-techno.com/system/files/cn/%5B1-5948-003%5DG3L_LTE%E3%83%A2%E3%82%B8%E3%83%A5%E3%83%BC%E3%83%AB%E3%81%AE%E4%B8%8D%E5%85%B7%E5%90%88%E3%81%AB%E9%96%A2%E3%81%97%E3%81%A6.pdf

この問題に該当している場合、モジュールのIMEIが初期化されてしまいっているため、データ取得することができません。

大塩様

ありがとうございます。
いただいた資料の問題である可能性が高いと思います。
対応は検討いたします。

ところで、IMEIがunknownを表示される問題ですが、equipment idを見たらよいという情報を得ました。
確かにmmcliコマンドでequipment idにもIMEIが表示されているようです。
ただし、IMEIが正しく表示される機器はequipment idもそのように表示されますが、unknownを表示される機器は16進のアスキーコードで表示されているように見えます。
変換してみるとそれらしい数値になりました。