ATDE5でOpenJDK8がインストールできない

上園です。

ATDE5にEclipse IDE for C/C++ Developers を導入しインストールまでできたのですが、
javaリビジョンが1.8でないと起動できないため、OpenJDK8をインストールしようしたのですが
インストールできませんでした。

恐縮ながら、解決方法をご存知の方がいらっしゃいましたら
ご教示いただけないでしょうか。

まずは「/etc/apt/sources.list」が初期状態で、以下のコマンドを実行しました。

 sudo apt-get update
 sudo apt-get install openjdk-8-jdk

そのあとで

 E:パッケージ openjdk-8-jdk が見つかりません

と表示され、インストールできません。

次に、インストールするためミラーサイトの設定を行い上記のコマンドを実行しましたが、
 
 W:これらの問題を解決するためには apt-get updateを実行する必要があるかもしれません
 E:問題を解決することができません。壊れた変更禁止パッケージがあります。

が表示されます。再度コマンドを入力しても同じ現象となります。

ちなみに、ミラーサイトの設定は以下のページを参照し、sources.listに追記しました。

https://packages.debian.org/stretch/amd64/openjdk-8-jdk/download

/etc/apt/sources.listを添付しますが、他に必要な情報がありましたら
ご指摘いただくようお願いいたします。

ファイル名 ファイルの説明
sources.list_.txt
製品: 
Armadillo-440

溝渕です。

> 上園です。
>
> ATDE5にEclipse IDE for C/C++ Developers を導入しインストールまでできたのですが、
> javaリビジョンが1.8でないと起動できないため、OpenJDK8をインストールしようしたのですが
> インストールできませんでした。

次のようにインストールしている人がいました。
http://linuxg.net/how-to-install-the-oracle-java-8-on-debian-wheezy-and-debian-jessie-via-repository/

# 私は試したことがありません。できなかったらすみません。

> まずは「/etc/apt/sources.list」が初期状態で、以下のコマンドを実行しました。
>
>  sudo apt-get update
>  sudo apt-get install openjdk-8-jdk
>
> そのあとで
>
>  E:パッケージ openjdk-8-jdk が見つかりません
>
> と表示され、インストールできません。

Debian GNU/Linux 7(wheezy)にはopenjdk-8が無いためにエラーとなります。

> ちなみに、ミラーサイトの設定は以下のページを参照し、sources.listに追記しました。
>
> https://packages.debian.org/stretch/amd64/openjdk-8-jdk/download

上記、Debian GNU/Linux 9(stretch)のミラーですね。パッケージバージョン
の依存関係の解決は困難かと思います。

溝渕様

お世話になっております、上園です。

度重なるご指摘いただき、誠にありがとうございます。

> 次のようにインストールしている人がいました。
> http://linuxg.net/how-to-install-the-oracle-java-8-on-debian-wheezy-and-debian-jessie-via-repository/

 「Debian 7 Wheezy:」の手順で実行してみましたが、apt-get updateとapt-get install oracle-java8-installerで
  それぞれ同じメッセージが表示され、インストールできませんでした。

> Debian GNU/Linux 7(wheezy)にはopenjdk-8が無いためにエラーとなります。

 ATD5にはopenjdkは6と7がインストール済なのは確認しています。

 ちなみに、現在のjavaのバージョンは「1.7.0_151」です。
 
> > https://packages.debian.org/stretch/amd64/openjdk-8-jdk/download
>
> 上記、Debian GNU/Linux 9(stretch)のミラーですね。パッケージバージョン
> の依存関係の解決は困難かと思います。

 なるほど、Debian GNU/Linux 7(wheezy)でも同じミラーが使用できると思っていましたが
 違っていたのですね。それだけでも収穫です。

引き続き、調査を行います。