RS422通信時の設定について

RS422による通信で、送信は出来ますが、受信ができません。

Armadillo側は minicom を使用してデータを送信すると対向側でデータを受信できます。
一方、対向側からArmadilloに向けて送信しても、minicom にデータが表示されない状態です。

ケーブルの断線を疑い、Rx/Tx で線を入れ替えても状況は変わりません

保守モードで、Linux起動オプションを以下の通り設定しましたが、不備・不足がありますでしょうか?

setenv optargs imx.rs485_uart2=0x02,0,0

製品: 
Armadillo-IoT G3L

自己解決です。

起動オプションを以下の通りとして RS422 送受が出来るようになりました。

setenv optargs imx.rs485_uart2=0x13,0,0

RS422 通信時は bit0 で「RS485無効」とする必要があると思っていましたが、RS422 でも「RS485有効」なのですね。

参考までに、「RS485無効」とはどういう状態でしょうか?

古関です。

> 参考までに、「RS485無効」とはどういう状態でしょうか?
シリアルのドライバーがRS232Cモードで動作します。

現在、ご利用になっているArmadillo-IoT G3LのCON4シリアルインターフェースでは
RS422/RS485のみ対応で、RS232Cは非対応となります。

別製品のArmadillo-IoT G3やArmadillo-X1でもArmadillo-IoT G3Lと
共通のカーネル・シリアルのドライバーを利用しており、
下記のアドオンモジュールではRS232Cに対応しております。
https://armadillo.atmark-techno.com/option-products/OP-AGA-RS00-00
https://armadillo.atmark-techno.com/option-products/OP-AGA-RS01-00

古関様

ご回答ありがとうございました。

G3L では「RS485無効」は無意味ということですね。
承知いたしました。

> 古関です。
>
> > 参考までに、「RS485無効」とはどういう状態でしょうか?
> シリアルのドライバーがRS232Cモードで動作します。
>
> 現在、ご利用になっているArmadillo-IoT G3LのCON4シリアルインターフェースでは
> RS422/RS485のみ対応で、RS232Cは非対応となります。
>
> 別製品のArmadillo-IoT G3やArmadillo-X1でもArmadillo-IoT G3Lと
> 共通のカーネル・シリアルのドライバーを利用しており、
> 下記のアドオンモジュールではRS232Cに対応しております。
> https://armadillo.atmark-techno.com/option-products/OP-AGA-RS00-00
> https://armadillo.atmark-techno.com/option-products/OP-AGA-RS01-00