Armadillo-640 イメージディスクからのインストールができない

お世話になっております、上園です。

Armadillo-640でイメージディスクを使用して初期化しようとしたのですが、
途中でメッセージで起動が止まってしまい、コマンドも実行できない状況です。
どの様にして復旧できますでしょうか?

メッセージログを添付しますので、ご教示をお願いします。

イメージディスク作成は、ユーザサイドの11章「イメージファイルの書き換え方法」で
イメージディスクを作成しました。

使用したインストールディスクイメージは「install-disk-sd-a640-20191030.img」です。

MicroSDカードの不具合を考え、3枚のMicroSDカードでイメージディスクを作成しましたが、
すべて同じ所で起動が停止しました。

お手数ですが、よろしくお願いいたします。

ファイル名 ファイルの説明
イメージ書き換えlog.txt
製品: 
Armadillo-640

起動ログを見る限りインストールディスクではなく
通常のDebianが起動しているように見えます。

JP1,JP2はともにショートされているでしょうか。

上園です、ご教示ありがとうございます。

> 起動ログを見る限りインストールディスクではなく
> 通常のDebianが起動しているように見えます。
>
> JP1,JP2はともにショートされているでしょうか。

JP1,JP2は共にショートしています。

ジャンパピンの問題かと思い手持ちの物を使ってみましたが、
現象は変わりませんでした。

以上、よろよろしくお願いいたします。

溝渕です。

U-Bootの環境変数を変更しましたか?

以下のコマンドの出力を教えてください。

=> env print -a

溝渕様

お世話になっております、上園です。

> U-Bootの環境変数を変更しましたか?
>
> 以下のコマンドの出力を教えてください。
>
>

> => env print -a
> 

SDカードのブート後のコマンド実行結果は以下の通りになります。

---------------------------------------------------------------
CPU: Freescale i.MX6ULL rev1.0 at 396 MHz
Reset cause: POR
I2C: ready
DRAM: 512 MiB
MMC: FSL_SDHC: 0, FSL_SDHC: 1
Loading Environment from MMC... *** Warning - bad CRC, using default environment

Failed (-5)
In: serial
Out: serial
Err: serial
PMIC: PFUZE3000 DEV_ID=0x30 REV_ID=0x11
Net: FEC
=> env print -a
baudrate=115200
bootcmd=run setup_mmcargs; ext4load mmc 0:2 ${loadaddr} /boot/uImage; ext4load mmc 0:2 0x83000000 /boot/a640.dtb; bootm ${loadaddr} - 0x83000000;
bootdelay=0
enable_pf3000_lpm=no
ethact=FEC
ethaddr=00:11:0c:2a:05:1d
loadaddr=0x82000000
setup_mmcargs=setenv bootargs root=/dev/mmcblk0p2 rootwait ${optargs};
stderr=serial
stdin=serial
stdout=serial
stop_nr3225sa_alarm=no;
tftpboot=tftpboot uImage; tftpboot 0x83000000 a640.dtb; bootm ${loadaddr} - 0x83000000;

Environment size: 503/524284 bytes
=>
-----------------------------------------------------------------

以上、よろしくお願いいたします

 

溝渕です。

U-Bootの環境変数で、eMMCを使うようになってしまっています。

インストールディスクを再度作成するか、以下のコマンドを入力してみていただけますか?

=> env default -a
=> saveenv

溝渕様

お世話になっております、上園です。

> U-Bootの環境変数で、eMMCを使うようになってしまっています。
>
> インストールディスクを再度作成するか、以下のコマンドを入力してみていただけますか?
>
>

> => env default -a
> => saveenv
> 

>

コマンド実行した結果は以下の通りです。

---------------------------------------------------------------------------------------

U-Boot 2018.03-at4 (Dec 26 2018 - 19:21:13 +0900)

CPU: Freescale i.MX6ULL rev1.0 at 396 MHz
Reset cause: POR
I2C: ready
DRAM: 512 MiB
MMC: FSL_SDHC: 0, FSL_SDHC: 1
Loading Environment from MMC... *** Warning - bad CRC, using default environment

Failed (-5)
In: serial
Out: serial
Err: serial
PMIC: PFUZE3000 DEV_ID=0x30 REV_ID=0x11
Net: FEC
=> env default -a
## Resetting to default environment
=> saveenv
Saving Environment to MMC... Writing to MMC(0)... OK
=>

---------------------------------------------------------------------------------------

コマンド実行後に電断し、再度bootコマンドを実行しましたが現象は同じでした。
(添付したログファイル参照)

SDカードを取り換えてイメージファイルを作り直してみます。

以上、よろしくお願いいたします。

ファイル名 ファイルの説明
イメージ書き換えlog2.txt

溝渕です。

こちらでも「install-disk-sd-a640-20191030.img」を使って確認してみましたが、正常にインストールが実行されました。

お手数ですが、再度インストールディスクを作成し、インストールの実行を行ってみていただけますか。

その際の(インストールディスク作成からの)ログもいただけると、以降アドバイスがしやすいのでお願いいたします。

溝渕様

お世話になっております、上園です。

サイトからイメージファイルをダウンロードしなおし、SDカードの取り換えてみました。
結果としては、前と同じでした。
(添付ファイルのログ参照)

イメージファイルの作成は、WindowS PCで実行しました。
(SDカードへの書き込みは、Win32DiskImagerを使用)

念のため、ATDE環境でイメージディスクの作成をおこなってみます)

以上、よろしくお願いいたします。

ファイル名 ファイルの説明
イメージ書き換えlog3.txt

お世話になっております、上園です。

ATDE環境でイメージディスクを作成してみましたが、結果は同じでした。

もう一台別のArmadillo-640がありますので、作成したSDカードインストールを行ったところ、
こちらは問題なくインストールが完了しました。
(カーネルバージョンが、v4.14-at15であることを確認)

よって、SDカードやイメージファイルの不具合ではなく、
Armadillo-640の一台が問題ではないかと思います。
 
他にご指摘があればご教示をお願いしたく存じます。

以上、よろしくお願いいたします。

溝渕です。

ご確認ありがとうございます。

該当個体に問題がある可能性が高いです。

以下の内容をご確認の上、Webフォームからお問い合わせをお願い致します。

[製品保証について]
https://users.atmark-techno.com/support/warranty

お手数ですが宜しくお願いいたします。

溝渕様

お世話になっております、上園です。

640単体で実行したところ、イメージ書き込みができることを確認しました。

原因は、LCD 拡張インターフェース(CON11)にLCDを付けたまま
イメージ書き込みを実行していていました。

CON11からフラットケーブルを外して640単体で実行したところ、
問題なくイメージの書き込みが実行でき、カーネルのバージョンアップも確認できました。
(念のため、ログを添付しておきます)

再度CON11にLCDケーブルを接続し、640が正常に起動するところまで確認済です。
今も動作させていますが、特に問題はないので製品の故障ではないと思います。

この度は、ご協力いただきまして有難うございました。
また、お手数をお掛けして申し訳ありませんでした。

ファイル名 ファイルの説明
イメージ書き換えlog4.txt

> 原因は、LCD 拡張インターフェース(CON11)にLCDを付けたまま
> イメージ書き込みを実行していていました。

このLCDはオリジナルの基板でしょうか?

LCDオプションセット(7インチタッチパネルWVGA液晶)
https://armadillo.atmark-techno.com/option-products/OP-LCD70EXT-L00

ではこの状態が起きないよう設計されているのですが、
もし一般に販売されているものであれば、可能であればLCDを教えていただきたいです。

溝渕様

お世話になっております、上園です。

> このLCDはオリジナルの基板でしょうか?

オプションセットではなく、外部から購入した基盤です。

> もし一般に販売されているものであれば、可能であればLCDを教えていただきたいです。

基盤設計した者が本日休暇なので、明日確認してみます。
汎用品なので、型番の公開はできると思います。

溝渕です。

CON11(LCD拡張インターフェース)のいくつかのピンは、ブートモード設定ピンとなっています。

https://manual.atmark-techno.com/armadillo-640/armadillo-640_product_manual_ja-1.12.0/ch16.html#sct.con11

> CON11のブートモード設定ピンについて
>
> CON11の13〜18、20〜25、27〜32ピン(LCD_DATA00〜17)は、i.MX6ULLの内蔵ROM
> によるブートモード設定ピンを兼用しています。 電源投入時、ブードモード
> 設定のために、基板上のプルアップ/ダウン抵抗で、High/Lowレベルの状態を
> 保持しています。 意図しない動作を引き起こす原因となるため、電源投入時
> からU-Bootが動作するまでは、 各々のピンをHigh/Lowレベルに保持した状態
> でご使用ください。 ブートモード設定の詳細につきましては、NXP
> Semiconductorsのホームページからダウンロード可能な 『i.MX6ULL
> Applications Processor Reference Manual』をご参照ください。

LCDがそれらのピンをドライブした場合、意図しないブートモードになってし
まう可能性があります。

溝渕様

お世話になっております、上園です。
ご連絡が遅れまして申し訳ございません。

LCDですが、ZETTLER DISPLAYSの「ACM1602NI-FLW-FBW-M01」です。

CON11にはLCDの他にCAN1/2やUART4/5などのデバイスも接続しています。

物理的に接続しているので、デバイスを接続している状態では
ブートモードの設定ができていない状態となっていると思います。

基盤を作成した担当に、上記の内容を伝えて社内での検討を行います。

いろいろとご教示いただきましてありがとうございました。