このエントリーをはてなブックマークに追加

Armadillo-840のHDMI出力について

お世話になります。
Armadillo-840のHDMI出力について質問させてください。

Armadillo-840からHDMIで画像を出力(解像度1920x1080)した際、画像が一回り大きく出力されているらしく、
画像の端が表示されない状態となってしまいます。
→上下左右30ピクセル程度

プログラム上でQtのメインウィンドウのサイズを確認したところ、1920x1080と正しい値になっている為、
出力しようとしているデータが正しいと思います。。

また、プログレッシブモードに変更すると改善します。
> echo D:1920x1080p-60 > /sys/class/graphics/fb0/mode
しかし、HDMIケーブルの挿抜を行うと元に戻ってしまう状態です。

現象が発生している際の、fbsetの状態は以下の通りです。
====================================================
mode "1920x1080-30"
        # D: 74.250 MHz, H: 33.750 kHz, V: 30.027 Hz
        geometry 1920 1080 1920 4320 32
        timings 13468 148 88 30 4 44 10
        accel false
        rgba 8/16,8/8,8/0,8/24
endmode
====================================================

プログレッシブモードでは以下の通りです。
====================================================
mode "1920x1080-60"
        # D: 148.500 MHz, H: 67.500 kHz, V: 60.000 Hz
        geometry 1920 1080 1920 4320 32
        timings 6734 148 88 36 4 44 5
        accel false
        rgba 8/16,8/8,8/0,8/24
endmode
====================================================

インターレースモードでも正しく表示させる方法、または、常にプログレッシブモードで
動作させる方法などご存知の方がいましたら、ご教授願います。
できればなぜこのような現象が発生するのかなども併せて教えていただけると助かります。

よろしくお願い致します。
以上です。

製品: 

  • Armadillo-840

花田です。

花田です。

> Armadillo-840からHDMIで画像を出力(解像度1920x1080)した際、画像が一回り大きく出力されているらしく、
> 画像の端が表示されない状態となってしまいます。
> →上下左右30ピクセル程度

モニター側のオーバースキャン調整が利いている状態と思われます。数字的には98%程度ですね。
三菱RDT232WXで、1080iを入力したときに初期設定のままでこの状態になった覚えがあります。

後継品RDT234WXのマニュアルですが
https://dl.mitsubishielectric.co.jp/dl/ldg/wink/ssl/wink_doc/m_contents/wink/D_MENT_DOC/manual_rdt234wx_z.pdf
P.35に
> AV信号を表示する場合、映像によっては画面の周囲にノイズが見えることがあります。
> 「オーバースキャン」の設定を変更することで、画面の外周部をカットし、ノイズを隠すことができます。
> 100%/フル:
> 98%:
> 95%:
> 93%:
この設定ですね。お使いのモニタに同様の設定項目がないか、ご確認ください。

花田様

花田様

ご回答、ありがとうございます。
モニターの設定項目を確認したのですが、該当の項目がありませんでした。
→モニターはDELLのP2417Hです。

現象的には、かなり適合しているので、もう少しその線で調べたいと思います。
有益な情報、ありがとうございます。

OverScanの無効化について調査したのですが

OverScanの無効化について調査したのですが、どうもDELLのモニターでは設定ができないようです。
常にプログレッシブモードで動作するようにしたいのですが、やり方をご存知の方がいましたら、ご教授願います。
よろしくお願い致します。

http://manual.atmark-techno

http://manual.atmark-techno.com/armadillo-840/armadillo-840_product_manual_ja-1.2.0/ch08.html
の「ビデオモード自動調整機能」の情報を基に /etc/config/configure-fbmode.sh を確認したところ、
”IGNORE_MODE_1='1920x1080p-60'”と1920x1080p-60が無効なモードに指定されていることが分かりました。
上記を”IGNORE_MODE_1='0x0-0'”に変更したところ、プログレッシブモードで認識されるようになったのですが、
1920x1080p-60が無効になっている理由などがあるのでしょうか?
ご存知の方がいましたら、教えてください。
よろしくお願い致します。

溝渕様

溝渕様

ご回答、ありがとうございます。
きちんと記載されていたのですね。
確認不足ですみません。

R-Mobile A1の制約というのはわかったのですが、実際には設定可能で表示もできているように見えます。
1920x1080p-60の設定で動作させた場合、どのような問題が発生する可能性があるのでしょうか?
重ねての質問で申し訳ありませんが、ご教授いただけると助かります。

よろしくお願い致します。

溝渕です。

溝渕です。

> R-Mobile A1の制約というのはわかったのですが、実際には設定可能で表示もできているように見えます。
> 1920x1080p-60の設定で動作させた場合、どのような問題が発生する可能性があるのでしょうか?

どのような問題が発生するかは不明ですが、IPコアの仕様として正常動作は期待できません。

該当制約についてはデータシートで明言されているため、例え描画できていた
としてもこちらからはお勧めができません。

あまり有益な回答ではありませんが、少しでも参考になれば。

溝渕様

溝渕様

ご回答、ありがとうございます。
非公式な使用の仕方は控えた方が良さそうですね。
インターレースでも、OverScanが解除できれば問題ないのですが。。。

ご教授、ありがとうございました。
勉強になりました。
以上です。