libusbのインストールについて

いつもお世話になっております。
中井です。

下記のlibusbのインストールを行いましたが、うまくいきません。

特集 : 最新組み込みLinux実践講座Part5
http://armadillo.atmark-techno.com/articles/sd-a500-embedded-course-ch5

$ cd ~/work.sd
$ wget http://ftp.jp.debian.org/debian/pool/main/libu/libusb/libusb-0.1-4_0.1.12-5_arm.deb
$ wget http://ftp.jp.debian.org/debian/pool/main/libu/libusb/libusb-dev_0.1.12-5_arm.deb
$ dpkg-cross -a arm -b libusb-0.1-4_0.1.12-5_arm.deb libusb-dev_0.1.12-5_arm.deb
# dpkg -i libusb-0.1-4-arm-cross_0.1.12-5_all.deb libusb-dev-arm-cross_0.1.12-5_all.deb

最初のwgetで、以下のエラーが発生します。

atmark@atde5:~/ダウンロード$ wget http://ftp.jp.debian.org/debian/pool/main/libu/libusb/libusb-0.1-4_0.1.12-5_arm.deb
--2014-02-26 14:02:50-- http://ftp.jp.debian.org/debian/pool/main/libu/libusb/libusb-0.1-4_0.1.12-5_arm.deb
ftp.jp.debian.org (ftp.jp.debian.org) をDNSに問いあわせています... 133.242.8.20
ftp.jp.debian.org (ftp.jp.debian.org)|133.242.8.20|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 404 Not Found
2014-02-26 14:02:50 エラー 404: Not Found。

これは、ライブラリのバージョンが正しくないからでしょうか。
であれば、最新のバージョンがどれか、確認する方法はありますでしょうか。
また、最初のcdは「ダウンロード先は任意でよい」という意味でしょうか。

【使用環境】
仮想マシン : atde5-amd64-20140131
ディストリビューション : atmark-dist-20140131
カーネル : linux-3.4-at6

以上、よろしくお願いいたします。

製品: 
Armadillo-840

wgetで失敗するのは、記事を書いた当時のdebianリポジトリの
アドレスを参照しているからですね。
Armadillo-840であれば下記のアドレスに置き換えて試してみてください。
http://ftp.jp.debian.org/debian/pool/main/libu/libusb/libusb-dev_0.1.12-23.3_armhf.deb
http://ftp.jp.debian.org/debian/pool/main/libu/libusb/libusb-0.1-4_0.1.12-23.3_armhf.deb
 
記事内ではlibusb0.1を使っていますが、libusb1.0を使用するのであれば
ATDE5 v20140131にはlibusb1.0のクロスパッケージがインストール済みです。
 
ATDEにインストールされているlibusbのバージョンはコンソールで次のようにすると
確認できます。

[ATDE ~]$ dpkg -l |grep libusb.*cross.*

 
libusb0.1と1.0とではAPIが違うので、最近書かれたlibusbを使ったプログラムでは
1.0が必要になるかもしれません。
 
>また、最初のcdは「ダウンロード先は任意でよい」という意味でしょうか。
そうです。dpkg -iでインストールした後は不要なのでどこでも構いません。